Potential Degraded Performance- Russia
Incident Report for FreeStyle Libre Server
Resolved
This incident has been resolved.
Posted Feb 21, 2024 - 18:55 PST
Investigating
We are actively looking into a potential outage and will provide an update as soon as we have more information. We will continue to post updates here.
Posted Feb 21, 2024 - 06:14 PST
This incident affected: LibreView Web App (Russia).