FreeStyle LibreLink App Outage
Incident Report for FreeStyle Libre Server
Resolved
This incident has been resolved.
Posted Nov 20, 2023 - 12:24 PST
Monitoring
Our team is working around the clock to resolve the ongoing outage. Please check back with this site as we will keep posting updates to the situation here. Thank you for your patience.
Posted Nov 20, 2023 - 11:10 PST
This incident affected: FreeStyle LibreLink, FreeStyle Libre 2, FreeStyle Libre 3 Mobile App* (Account Registration, Connected Apps, Australia, New Zealand), LibreView Web App (Account Registration, Australia, New Zealand), LibreLinkUp Mobile App (Account Registration, Australia, New Zealand), and Libre Data Sharing API (Australia, New Zealand).