FreeStyle LibreLink App Outage
Incident Report for FreeStyle Libre Server
Resolved
This incident has been resolved.
Posted Feb 22, 2024 - 17:19 PST
Monitoring
We are continuing to resolve the unexpected outage.
Posted Feb 22, 2024 - 16:12 PST
This incident affected: FreeStyle LibreLink, FreeStyle Libre 2, FreeStyle Libre 3 Mobile App* (Account Registration, Europe, Middle East, Africa), Libre Data Sharing API (Europe, Middle East, Africa), LibreView Web App (Europe, Middle East, Africa), and LibreLinkUp Mobile App (Europe, Middle East, Africa).