Potential Outage

Incident Report for FreeStyle Libre Server

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 10:01 PDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 20, 2025 - 12:17 PDT

Identified

We are actively looking into a potential outage and will provide an update as soon as we have more information.

We will continue to post updates here.
Posted Mar 20, 2025 - 12:17 PDT
This incident affected: LibreView Web App (Account Registration, Europe, Middle East, Africa, Russia), LibreLinkUp Mobile App (Account Registration, Europe, Middle East, Africa, Russia, Canada), Libre Data Sharing API (Europe, Middle East, Africa), and Libre App, FreeStyle LibreLink, FreeStyle Libre 2, FreeStyle Libre 3 Mobile App* (Russia).