LibreView App Outage

Incident Report for FreeStyle Libre Server

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 16:23 PST

Update

We are continuing to monitor for any further issues.
Posted Mar 02, 2026 - 12:28 PST

Update

We are continuing to monitor for any further issues.
Posted Mar 02, 2026 - 12:28 PST

Update

We are continuing to monitor for any further issues.
Posted Mar 02, 2026 - 12:00 PST

Update

We are continuing to monitor for any further issues.
Posted Mar 02, 2026 - 11:27 PST

Monitoring

Our team is working around the clock to resolve the ongoing outage. Please check back with this site as we will keep posting updates to the situation here. Thank you for your patience.
Posted Mar 02, 2026 - 11:25 PST
This incident affected: Libre App, FreeStyle LibreLink, FreeStyle Libre 2, FreeStyle Libre 3 Mobile App* (Account Registration, United Arab Emirates), LibreView Web App (Account Registration, United Arab Emirates), LibreLinkUp Mobile App (Account Registration, United Arab Emirates), and Libre Data Sharing API (United Arab Emirates).